CentOS 8 下的第三方套件及模組

CentOS 8 引入了模組。它們的目的是讓用戶能選用同一套件的不同版本 —— 但這個措施卻為第三方套件帶來一些困難。

在 CentOS 8 下,要是一個套件是由模組所提供的 —— 就算該模組已被停用 —— 它依然較非模組的套件較為優先。意思就是,如果 foobar:1.0 模組提供了 foo 套件,你便無法從其它地方安裝名為 foo 的套件。

唯一的權宜之計就是編輯第三方軟件庫的設定檔,檔名類似 /etc/yum.repos.d/myrepo.repo,並加入以下一行:

module_hotfixes=true

此後,你便能如常從第三方軟件庫安裝套件。

Translation of revision 1

zh-tw/TipsAndTricks/3pModules (last edited 2020-10-17 03:28:50 by TimothyLee)